summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 10:42:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:18 +0100
commit215ccb997ad0dc2dced12cb17598472a7d12d83e (patch)
treed70784229c0e04f7fbaf8c31c85c89d4b21baaae /gnu/packages/xfce.scm
parent35faa006864efb2475524d121053893e73015ef1 (diff)
downloadpatches-215ccb997ad0dc2dced12cb17598472a7d12d83e.tar
patches-215ccb997ad0dc2dced12cb17598472a7d12d83e.tar.gz
gnu: xfconf: Use INVOKE.
* gnu/packages/xfce.scm (xfconf)[arguments]: Unconditionally return #T from check phase.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 79eb64d13a..b47fe5d301 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Florian Paul Schmidt <mista.tapas@gmx.net>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -126,7 +126,7 @@ Xfce Desktop Environment.")
(string-append %output "/share"))
;; For the missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0");
- (zero? (system* "dbus-launch" "make" "check"))))
+ (invoke "dbus-launch" "make" "check")))
(delete 'check))))
(native-inputs
`(("pkg-config" ,pkg-config)