summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-10 19:40:26 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-12 20:41:51 +0800
commit55613927ea9ae7a465dc2a79128e7b65e47ec99e (patch)
treea8aae34eed1ff599884692e73ad08b6d9cba6cbf /gnu/packages/xfce.scm
parent9a8a040dfe1a8e60949f1204bd5b0dc73d5541b4 (diff)
downloadpatches-55613927ea9ae7a465dc2a79128e7b65e47ec99e.tar
patches-55613927ea9ae7a465dc2a79128e7b65e47ec99e.tar.gz
gnu: Add xfce4-settings.
* gnu/packages/xfce.scm (xfce4-settings): New variable.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index c94d2696d4..82296fafec 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -321,3 +321,34 @@ your system in categories, so you can quickly find and launch them.")
"Session manager for Xfce, it will restore your session on startup and
allows you to shutdown the computer from Xfce.")
(license gpl2+)))
+
+(define-public xfce4-settings
+ (package
+ (name "xfce4-settings")
+ (version "4.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/xfce/"
+ (version-major+minor version)
+ "/src/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0zppq747z9lrxyv5zrrvpalq7hb3gfhy9p7qbldisgv7m6dz0hq8"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("exo" ,exo)
+ ("garcon" ,garcon)
+ ("libnotify" ,libnotify)
+ ("libxcursor", libxcursor)
+ ("libxi" ,libxi)
+ ("libxrandr" ,libxrandr)
+ ("libxfce4ui" ,libxfce4ui)))
+ (home-page "http://www.xfce.org/")
+ (synopsis "Xfce settings manager")
+ (description
+ "Settings manager for Xfce, it can control various aspects of the desktop
+like appearance, display, keyboard and mouse settings.")
+ (license gpl2+)))