summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:23 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:27:01 +0200
commit415e7e2046ea8eeb7fa0cf3ccb51429be2ca2627 (patch)
tree3158da703568f218233b2d885f1b2b6ac612c8a1 /gnu/packages/xfce.scm
parentc6927c08bde76d83758674747ca718cf543772aa (diff)
downloadpatches-415e7e2046ea8eeb7fa0cf3ccb51429be2ca2627.tar
patches-415e7e2046ea8eeb7fa0cf3ccb51429be2ca2627.tar.gz
gnu: Add xfce4-timer-plugin.
* gnu/packages/xfce.scm (xfce4-timer-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index ec699a79df..e3ff59eed1 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1230,6 +1230,34 @@ A plugin for the Xfce panel is also available.")
the volume using multimedia keys. It also provides volume change notifications.")
(license gpl3+)))
+(define-public xfce4-timer-plugin
+ (package
+ (name "xfce4-timer-plugin")
+ (version "1.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-timer-plugin/"
+ (version-major+minor version)
+ "/xfce4-timer-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "16vypwwjwfk7nn4n16rfgn0z78jqrmbgxmc1r46269lrwd1m6kif"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-timer-plugin")
+ (synopsis "Simple countdown and alarm plugin for the Xfce panel")
+ (description "This is a simple plugin that lets the user run an
+alarm at a specified time or at the end of a specified countdown
+period.")
+ (license gpl2+)))
+
(define-public xfce4-verve-plugin
(package
(name "xfce4-verve-plugin")