summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-30 14:46:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-30 19:47:50 +0200
commitcab1c1174182fadfd1ae39762d8f18314c2749db (patch)
treeca4682c87e9e8616160f50b53975eb468bffee5b /gnu/packages/xdisorg.scm
parent6e82fb2c27725039203161d000fff9ff0dce8c97 (diff)
downloadpatches-cab1c1174182fadfd1ae39762d8f18314c2749db.tar
patches-cab1c1174182fadfd1ae39762d8f18314c2749db.tar.gz
gnu: Add xsel.
* gnu/packages/xdisorg.scm (xsel): New variable.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index a2230c4e93..2a345cb1b0 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -958,6 +958,32 @@ demos. It also acts as a nice screen locker.")
"http://metadata.ftp-master.debian.org/changelogs/"
"/main/x/xscreensaver/xscreensaver_5.36-1_copyright")))))
+(define-public xsel
+ (package
+ (name "xsel")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.vergenet.net/~conrad/software"
+ "/xsel/download/xsel-" version ".tar.gz"))
+ (sha256
+ (base32
+ "070lbcpw77j143jrbkh0y1v10ppn1jwmjf92800w7x42vh4cw9xr"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libxt" ,libxt)))
+ (home-page "http://www.vergenet.net/~conrad/software/xsel/")
+ (synopsis "Manipulate X selection")
+ (description
+ "XSel is a command-line program for getting and setting the contents of
+the X selection. Normally this is only accessible by manually highlighting
+information and pasting it with the middle mouse button.
+
+XSel reads from standard input and writes to standard output by default,
+but can also follow a growing file, display contents, delete entries and more.")
+ (license (license:x11-style "file://COPYING"
+ "See COPYING in the distribution."))))
+
(define-public xdpyprobe
(package
(name "xdpyprobe")