summaryrefslogtreecommitdiff
path: root/gnu/packages/wordnet.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-30 20:19:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-30 20:19:04 +0300
commit983911d62731c42702526c9a049181a89cafb443 (patch)
tree54c750c56def66ab3256ead4e4d779a684081c22 /gnu/packages/wordnet.scm
parentc1dbd3a8709f143fa72b2f893a069ca5f1afe7ac (diff)
downloadpatches-983911d62731c42702526c9a049181a89cafb443.tar
patches-983911d62731c42702526c9a049181a89cafb443.tar.gz
gnu: wordnet: Use 'modify-phases'.
* gnu/packages/wordnet.scm (wordnet)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/wordnet.scm')
-rw-r--r--gnu/packages/wordnet.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/wordnet.scm b/gnu/packages/wordnet.scm
index 9cd7a56104..dbc75860ef 100644
--- a/gnu/packages/wordnet.scm
+++ b/gnu/packages/wordnet.scm
@@ -52,30 +52,30 @@
;; Provide the `result' field in `Tcl_Interp'.
;; See <https://bugs.gentoo.org/show_bug.cgi?id=452034>.
"CFLAGS=-DUSE_INTERP_RESULT")
- #:phases (alist-cons-after
- 'install 'post-install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (bin (assoc-ref outputs "tk"))
- (tk (assoc-ref inputs "tk"))
- (tkv ,(let ((v (package-version tk)))
- (string-take v (string-index-right v #\.)))))
- ;; Move `wishwn' and `wnb' to BIN.
- (for-each (lambda (prog)
- (let ((orig (string-append out "/bin/" prog))
- (dst (string-append bin "/bin/" prog))
- (dir (string-append tk "/lib/tk" tkv)))
- (mkdir-p (dirname dst))
- (copy-file orig dst)
- (delete-file orig)
- (wrap-program dst
- `("TK_LIBRARY" "" = (,dir))
- `("PATH" ":" prefix
- (,(string-append out
- "/bin"))))))
- '("wishwn" "wnb"))
- #t))
- %standard-phases)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (bin (assoc-ref outputs "tk"))
+ (tk (assoc-ref inputs "tk"))
+ (tkv ,(let ((v (package-version tk)))
+ (string-take v (string-index-right v #\.)))))
+ ;; Move `wishwn' and `wnb' to BIN.
+ (for-each (lambda (prog)
+ (let ((orig (string-append out "/bin/" prog))
+ (dst (string-append bin "/bin/" prog))
+ (dir (string-append tk "/lib/tk" tkv)))
+ (mkdir-p (dirname dst))
+ (copy-file orig dst)
+ (delete-file orig)
+ (wrap-program dst
+ `("TK_LIBRARY" "" = (,dir))
+ `("PATH" ":" prefix
+ (,(string-append out
+ "/bin"))))))
+ '("wishwn" "wnb"))
+ #t))))))
(outputs '("out"
"tk")) ; for the Tcl/Tk GUI
(inputs `(("tk" ,tk)