summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMekeor Melire <mekeor.melire@gmail.com>2017-01-23 10:48:51 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-23 11:01:17 +0100
commit174b091fb744fe7aa83744a50629f7fc9e9110e4 (patch)
tree3a1db7bc13cdfb46871eccda8df681c1b0f6e820 /gnu/packages/wm.scm
parentc7bdb4139df22fbee40fb8dd717b96112110d5a7 (diff)
downloadpatches-174b091fb744fe7aa83744a50629f7fc9e9110e4.tar
patches-174b091fb744fe7aa83744a50629f7fc9e9110e4.tar.gz
gnu: xmonad: Update to 0.12.
* gnu/packages/wm.scm (xmonad): Update to 0.12. [source](snippet, modules): Remove. [inputs]: Add GHC-SETLOCALE and GHC-QUICKCHECK. (ghc-xmonad-contrib): Update to 0.12.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm28
1 files changed, 11 insertions, 17 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 5b761e81bb..8612867f4a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
;;; Copyright © 2016 Ivan Vilata i Balaguer <ivan@selidor.net>
+;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -320,7 +321,7 @@ prompt.")
(define-public xmonad
(package
(name "xmonad")
- (version "0.11.1")
+ (version "0.12")
(synopsis "Tiling window manager")
(source (origin
(method url-fetch)
@@ -328,22 +329,15 @@ prompt.")
name "-" version ".tar.gz"))
(sha256
(base32
- "1pfjssamiwpwjp1qqkm9m9p9s35pv381m0cwg6jxg0ppglibzq1r"))
- (modules '((guix build utils)))
- (snippet
- ;; Here we update the constraints on the utf8-string package in
- ;; the Cabal file. We allow a newer version which is compatible
- ;; with GHC 7.10.2. The same change is applied on Hackage. See
- ;; <https://hackage.haskell.org/package/xmonad-0.11.1/revisions/>.
- '(substitute* "xmonad.cabal"
- (("utf8-string >= 0.3 && < 0.4")
- "utf8-string >= 0.3 && < 1.1")))))
+ "1mzx3p17ppgmi30q3phaj58x6kxn73pbbkn9v9gzgmd8skdlkxp8"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-mtl" ,ghc-mtl)
- ("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
- ("ghc-x11" ,ghc-x11)))
+ `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-setlocale" ,ghc-setlocale)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-x11" ,ghc-x11)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -376,7 +370,7 @@ tiled on several screens.")
(define-public ghc-xmonad-contrib
(package
(name "ghc-xmonad-contrib")
- (version "0.11.4")
+ (version "0.12")
(source
(origin
(method url-fetch)
@@ -384,7 +378,7 @@ tiled on several screens.")
"xmonad-contrib-" version ".tar.gz"))
(sha256
(base32
- "1g5cw9vvnfbiyi599fngk02zlmdhrf82x0bndhypkn6kybab6yd3"))))
+ "04gk449dxwmimmb6y2d2hvvmv91r91xlj879qzlyq0mcf723278k"))))
(build-system haskell-build-system)
(propagated-inputs
`(("ghc-mtl" ,ghc-mtl)