summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-03-18 15:40:15 -0400
committerKei Kebreau <kei@openmailbox.org>2017-03-21 11:15:08 -0400
commit4b0e63670119971864289d67fc1e11a438f58ea6 (patch)
tree1244b9207324a64877c01cc3732d52e870fe72ae /gnu/packages/wm.scm
parented428a58ec347a9fb48aa75d805fab665f0eb6f4 (diff)
downloadpatches-4b0e63670119971864289d67fc1e11a438f58ea6.tar
patches-4b0e63670119971864289d67fc1e11a438f58ea6.tar.gz
gnu: Adjust asciidoc-related build options.
Commits 9099a45792306fade2d9ca55138e49ef4f01f1ea and 3078821d1380c26c738be6b5d430c595327d401f make many package inputs and build configurations related to asciidoc obsolete. * gnu/packages/compton.scm (compton)[inputs]: Remove docbook-xml, libxml2 and libxslt. * gnu/packages/mail.scm (offlinemap)[native-inputs]: Remove libxslt. * gnu/packages/linux.scm (btrfs-progs)[native-inputs]: Remove docbook-xml. (perf)[inputs]: Remove docbook-xml and libxslt. * gnu/packages/text-editors.scm (kakoune)[native-inputs]: Remove libxslt. * gnu/packages/version-control.scm (cgit)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and libxslt. (cvs-fast-export)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and libxslt. * gnu/packages/web.scm (qutebrowser)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2, and libxslt. (tinyproxy)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and libxslt. * gnu/packages/wm.scm (awesome)[make-flags]: Remove XML_CATALOG_FILES flag. (i3-wm)[inputs]: Remove docbook-xml. [native-inputs]: Add libxml2.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm28
1 files changed, 7 insertions, 21 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7d76a2d202..b95f2e7a6f 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -177,26 +177,12 @@ commands would.")
(build-system gnu-build-system)
(arguments
`(#:make-flags
- (let* ((docbook-xsl-name-version ,(string-append
- (package-name docbook-xsl) "-"
- (package-version docbook-xsl)))
- (docbook-xsl-catalog-file (string-append
- (assoc-ref %build-inputs "docbook-xsl")
- "/xml/xsl/"
- docbook-xsl-name-version
- "/catalog.xml"))
- (docbook-xml-catalog-file (string-append
- (assoc-ref %build-inputs "docbook-xml")
- "/xml/dtd/docbook/catalog.xml")))
- ;; Reference the catalog files required to build the manpages.
- (list (string-append "XML_CATALOG_FILES=" docbook-xsl-catalog-file " "
- docbook-xml-catalog-file)
- "CC=gcc"
- (string-append "PREFIX=" %output)
- ;; This works around the following error:
- ;; 'error: ‘for’ loop initial declarations are only allowed in C99
- ;; or C11 mode'
- "CFLAGS=-std=c11"))
+ (list "CC=gcc"
+ (string-append "PREFIX=" %output)
+ ;; This works around the following error:
+ ;; 'error: ‘for’ loop initial declarations are only allowed in C99
+ ;; or C11 mode'
+ "CFLAGS=-std=c11")
;; The build system tries to build in a separate directory, but that
;; seems to be unnecessary.
#:configure-flags '("--disable-builddir")
@@ -215,7 +201,6 @@ commands would.")
("asciidoc" ,asciidoc)
("xmlto" ,xmlto)
("perl-pod-simple" ,perl-pod-simple)
- ("docbook-xml" ,docbook-xml)
("libx11" ,libx11)
("pcre" ,pcre)
("startup-notification" ,startup-notification)
@@ -226,6 +211,7 @@ commands would.")
("perl" ,perl)
("pkg-config" ,pkg-config)
;; For building the documentation.
+ ("libxml2" ,libxml2)
("docbook-xsl" ,docbook-xsl)))
(home-page "https://i3wm.org/")
(synopsis "Improved tiling window manager")