summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-03-11 20:17:34 +0100
committerRutger Helling <rhelling@mykolab.com>2019-03-11 20:28:41 +0100
commit2ff844f0900be711be2322258beadeaa68e7b8b7 (patch)
tree2b2b43cfb6272d8a98cb498b7c46b11c515f9741 /gnu/packages/wm.scm
parenteea969cf8da5f85cd197032bb965cafbe18c0408 (diff)
downloadpatches-2ff844f0900be711be2322258beadeaa68e7b8b7.tar
patches-2ff844f0900be711be2322258beadeaa68e7b8b7.tar.gz
gnu: Add sway.
* gnu/packages/wm.scm (sway): New variable.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 68a737dbab..fedea67cc4 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -81,6 +81,8 @@
#:use-module (gnu packages mpd)
#:use-module (gnu packages gl)
#:use-module (gnu packages video)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages man)
#:use-module (guix download)
#:use-module (guix git-download))
@@ -1151,3 +1153,48 @@ Wayland compositor")
(description "wlroots is a set of pluggable, composable, unopinionated
modules for building a Wayland compositor.")
(license license:expat))) ; MIT license
+
+(define-public sway
+ (package
+ (name "sway")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/swaywm/sway.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09cndc2nl39d3l7g5634xp0pxcz60pvc5277mfw89r22mh0j78rx"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'hardcode-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "meson.build"
+ (("scdoc.get_pkgconfig_variable..scdoc..")
+ (string-append "'" (assoc-ref inputs "scdoc")
+ "/bin/scdoc'")))
+ #t)))))
+ (inputs `(("cairo" ,cairo)
+ ("elogind" ,elogind)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("json-c" ,json-c)
+ ("libinput" ,libinput)
+ ("libxkbcommon" ,libxkbcommon)
+ ("pango" ,pango)
+ ("wayland" ,wayland)
+ ("wlroots" ,wlroots)))
+ (native-inputs `(("git" ,git)
+ ("libcap" ,libcap)
+ ("linux-pam" ,linux-pam)
+ ("mesa" ,mesa)
+ ("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)
+ ("wayland-protocols" ,wayland-protocols)))
+ (home-page "https://github.com/swaywm/sway")
+ (synopsis "Wayland compositor compatible with i3")
+ (description "Sway is a i3-compatible Wayland compositor.")
+ (license license:expat))) ; MIT license