summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-13 20:42:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-08-13 20:42:06 +0200
commit462ad9f56b9665b8d22960acee73ad91f1052c9c (patch)
tree814be463d6d0517e7db9b9e6f15dbc7516955674 /gnu/packages/wm.scm
parent7f5f61ae99321a7a6e08b0100cd428e11ce6a837 (diff)
parent1b1b006afd31c5526f34d157baef492c7dde2e9c (diff)
downloadpatches-462ad9f56b9665b8d22960acee73ad91f1052c9c.tar
patches-462ad9f56b9665b8d22960acee73ad91f1052c9c.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 02dfa0143f..709037da37 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -130,20 +130,19 @@ the leaves of a full binary tree.")
(define-public i3status
(package
(name "i3status")
- (version "2.12")
+ (version "2.13")
(source (origin
(method url-fetch)
(uri (string-append "https://i3wm.org/i3status/i3status-"
version ".tar.bz2"))
(sha256
(base32
- "06krpbijv4yi33nypg6qcn4hilcrdyarsdpd9fmr2cq46qaqiikg"))))
+ "0rhlzb96mw64z2jnhwz9nibc7pxg549626lz5642xxk5hpzwk2ff"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))
+ `(;; XXX: Do an "out of source" build to work around
+ ;; <https://github.com/i3/i3status/issues/339>.
+ #:out-of-source? #t
#:tests? #f)) ; no test suite
(inputs
`(("openlibm" ,openlibm)
@@ -155,7 +154,10 @@ the leaves of a full binary tree.")
("libcap" ,libcap)
("asciidoc" ,asciidoc)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("docbook-xsl" ,docbook-xsl)
+ ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
+ ("xmlto" ,xmlto)))
(home-page "https://i3wm.org/i3status/")
(synopsis "Status bar for i3bar, dzen2, xmobar or similar programs")
(description "i3status is a small program for generating a status bar for
@@ -170,14 +172,14 @@ commands would.")
(define-public i3-wm
(package
(name "i3-wm")
- (version "4.16.1")
+ (version "4.17")
(source (origin
(method url-fetch)
(uri (string-append "https://i3wm.org/downloads/i3-"
version ".tar.bz2"))
(sha256
(base32
- "0xl56y196vxv001gvx35xwfr25zah8m3xwizp9ycdgdc0rfc4rdb"))))
+ "1z8qmkkq9dhqmqy8sjw3rnpnmnb8v7lr456bs0qzp23bgpj17gjf"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -287,8 +289,6 @@ Despite the name it should work with any X11 window manager.")
(arguments
`(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
#:phases (modify-phases %standard-phases
- (add-after 'unpack 'autogen
- (lambda _ (invoke "sh" "autogen.sh")))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))