summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2019-06-18 00:22:46 +0200
committerGábor Boskovits <boskovits@gmail.com>2019-06-18 00:25:23 +0200
commit46dc940c9af3d8b48966d16e52273ba88e92f946 (patch)
treec0d8105b0d4bb5f9de4f6f0736b4858eaa848e00 /gnu/packages/wm.scm
parent4c32f116cd89d158960c93ada28c32f3738e7b16 (diff)
downloadpatches-46dc940c9af3d8b48966d16e52273ba88e92f946.tar
patches-46dc940c9af3d8b48966d16e52273ba88e92f946.tar.gz
gnu: Add mako.
* gnu/packages/wm.scm (mako): New variable.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 0b15801633..90bc7fc883 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1365,3 +1365,31 @@ modules for building a Wayland compositor.")
(description "Waybar is a highly customisable Wayland bar for Sway and
Wlroots based compositors.")
(license license:expat))) ; MIT license
+
+(define-public mako
+ (package
+ (name "mako")
+ (version "1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/mako.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17azdc37xsbmx13fkfp23vg9lznrv9fh6nhagn64wdq3nhsxm3b6"))))
+ (build-system meson-build-system)
+ (inputs `(("cairo" ,cairo)
+ ("elogind" ,elogind)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("pango" ,pango)
+ ("wayland" ,wayland)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)
+ ("wayland-protocols" ,wayland-protocols)))
+ (home-page "https://wayland.emersion.fr/mako")
+ (synopsis "Lightweight Wayland notification daemon")
+ (description "Mako is a lightweight notification daemon for Wayland
+compositors that support the layer-shell protocol.")
+ (license license:expat))) ; MIT license