summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-06 14:24:04 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-06 18:02:48 +0200
commit1714edc3d4e8d6da1b0cdef300ae882d0885f182 (patch)
tree235533a075478a1475a12540afa1305d26b9b33e /gnu/packages/webkit.scm
parentc5ceec4150f6a6cdc1b64781afa2d05547cf8542 (diff)
downloadpatches-1714edc3d4e8d6da1b0cdef300ae882d0885f182.tar
patches-1714edc3d4e8d6da1b0cdef300ae882d0885f182.tar.gz
gnu: WebKitGTK: Embed absolute file name of libWPEBackend-fdo-1.0.so.
Fixes <https://bugs.gnu.org/37545>. Reported by Vagrant Cascadian <vagrant@debian.org>. * gnu/packages/webkit.scm (webkitgtk)[arguments]: Add phase.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 3169c7d15a..bda0fc6ba2 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -165,6 +165,13 @@ engine that uses Wayland for graphics output.")
"/xml/dtd/docbook/docbookx.dtd"))))
(find-files "Source" "\\.sgml$"))
#t))
+ (add-after 'unpack 'embed-absolute-wpebackend-reference
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((wpebackend-fdo (assoc-ref inputs "wpebackend-fdo")))
+ (substitute* "Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp"
+ (("libWPEBackend-fdo-([\\.0-9]+)\\.so" all version)
+ (string-append wpebackend-fdo "/lib/" all)))
+ #t)))
(add-after 'install 'move-doc-files
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))