summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorDavid Hashe <david.hashe@dhashe.com>2015-05-05 01:48:28 -0500
committerLudovic Courtès <ludo@gnu.org>2015-05-05 22:04:10 +0200
commit9ca3323608f183814a9313a08df3415075638aaf (patch)
tree4a30bcc95bb722d3ef6b4efadd7dd7cff65da73e /gnu/packages/webkit.scm
parentef80cceddc3646a299d3b7c30e9b32ad89cca021 (diff)
downloadpatches-9ca3323608f183814a9313a08df3415075638aaf.tar
patches-9ca3323608f183814a9313a08df3415075638aaf.tar.gz
gnu: webkitgtk: Fix compilation on x86_64.
* gnu/packages/webkit.scm (webkitgtk): Move library install path from lib64 to lib. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index e6de8ab0df..41b9b9a839 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -57,7 +58,12 @@
(arguments
'(#:tests? #f ; no tests
#:build-type "Release" ; turn off debugging symbols to save space
- #:configure-flags '("-DPORT=GTK")))
+ #:configure-flags (list
+ "-DPORT=GTK"
+ (string-append ; uses lib64 by default
+ "-DLIB_INSTALL_DIR="
+ (assoc-ref %outputs "out") "/lib"))
+ #:make-flags '("lib=lib"))) ; uses lib64 by default
(native-inputs
`(("bison" ,bison)
("gettext" ,gnu-gettext)