summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-10-21 18:32:11 +0100
committerChristopher Baines <mail@cbaines.net>2019-10-22 23:00:59 +0100
commit353f5f7aa7ea575f9f04d3a0b277bbb8012b942d (patch)
tree96458daa49d50a08713a30072bdf4f0cc610bff9 /gnu/packages/web.scm
parenta379ddaff4aaba107ceba66204cdc1021b7e800b (diff)
downloadpatches-353f5f7aa7ea575f9f04d3a0b277bbb8012b942d.tar
patches-353f5f7aa7ea575f9f04d3a0b277bbb8012b942d.tar.gz
gnu: guix-data-service: Enable build time tests.
Previously the tests were not run, as PostgreSQL wasn't running at build time. Now there's a new target, check-with-tmp-database that uses ephemeralpg to run the tests without relying on an externally managed PostgreSQL service. * gnu/packages/web.scm (guix-data-service)[arguments]: Remove #:tests? #f, and set #:test-target to "check-with-tmp-database". [native-inputs]: Add ephemeralpg.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3548c52411..af694b58d5 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4044,11 +4044,11 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
"0awfvps7k9bpg3gpgc93y401g7pjabx7mr9960vigad8vddhixqi"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; TODO Tests require PostgreSQL
- #:modules ((guix build utils)
+ '(#:modules ((guix build utils)
(guix build gnu-build-system)
(ice-9 rdelim)
(ice-9 popen))
+ #:test-target "check-with-tmp-database"
#:phases
(modify-phases %standard-phases
(add-after 'set-paths 'set-GUIX_ENVIRONMENT
@@ -4106,6 +4106,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
`(("guile" ,guile-2.2)
("autoconf" ,autoconf)
("automake" ,automake)
+ ("ephemeralpg" ,ephemeralpg)
("emacs-with-modules" ,(directory-union
"emacs-union"
(list emacs-no-x