summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-01 07:47:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-31 04:54:54 +0200
commitb8150fa091ce42c7837c6bfb9be8b96656470df2 (patch)
tree79f8001b9139107843fb81f6ed3eab7c81f3e6ca /gnu/packages/web.scm
parent16b5dafc4db79e0ebf6dbe48d0ed21c25d82edfe (diff)
downloadpatches-b8150fa091ce42c7837c6bfb9be8b96656470df2.tar
patches-b8150fa091ce42c7837c6bfb9be8b96656470df2.tar.gz
gnu: python-internetarchive: Use INVOKE.
* gnu/packages/web.scm (python-internetarchive)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5a87eb5f6e..0be62ac12c 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5239,12 +5239,12 @@ command-line arguments or read from stdin.")
(add-installed-pythonpath inputs outputs)
(setenv "PATH" (string-append (assoc-ref outputs "out") "/bin"
":" (getenv "PATH")))
- (zero? (system* "py.test" "-v" "-k"
- (string-append
- ;; These tests attempt to make a connection to
- ;; an external web service.
- "not test_get_item_with_kwargs"
- " and not test_ia"))))))))
+ (invoke "py.test" "-v" "-k"
+ (string-append
+ ;; These tests attempt to make a connection to
+ ;; an external web service.
+ "not test_get_item_with_kwargs"
+ " and not test_ia")))))))
(propagated-inputs
`(("python-requests" ,python-requests)
("python-jsonpatch" ,python-jsonpatch-0.4)