summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2019-07-09 15:35:51 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2019-07-09 20:41:14 +0300
commit38a9b4b74ee008d68dd0d6332a1092b552f1196f (patch)
treeb19c4560b35262a56af3ddcf008682ddb42c32c1 /gnu/packages/web.scm
parent710f027765079db7e5a9ea31faedf42e8748600c (diff)
downloadpatches-38a9b4b74ee008d68dd0d6332a1092b552f1196f.tar
patches-38a9b4b74ee008d68dd0d6332a1092b552f1196f.tar.gz
gnu: python-internetarchive: Update to 1.8.5.
* gnu/packages/web.scm (python-internetarchive)[version]: Update to 1.8.5. [source](modules, snippet): New fields.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm24
1 files changed, 18 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1eae6c7c3b..0a270e14f0 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5239,16 +5239,28 @@ command-line arguments or read from stdin.")
(define-public python-internetarchive
(package
(name "python-internetarchive")
- (version "1.7.4")
+ (version "1.8.5")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/jjjake/internetarchive/archive/"
- "v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jjjake/internetarchive")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0sdbb2ag6vmybi8zmbjszi492a587giaaqxyy1p6gy03cb8mc512"))))
+ "0ih7hplv92wbv6cmgc1gs0v35qkajwicalwcq8vcljw30plr24fp"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Python 3.7 removed `_pattern_type'.
+ (for-each (lambda (file)
+ (chmod file #o644)
+ (substitute* file
+ (("^import re\n" line)
+ (string-append line "re._pattern_type = re.Pattern\n"))))
+ (find-files "." "\\.py$"))
+ #t))))
(build-system python-build-system)
(arguments
`(#:phases