summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-02-13 13:17:15 -0500
committerMark H Weaver <mhw@netris.org>2018-02-13 13:17:15 -0500
commit288b8fd5e97c32d44a49612dbeef854c05ebc373 (patch)
tree8a5021c9af2497c560ff94d37b8217d6187d8dbd /gnu/packages/web.scm
parenta7fb29866520d5661e0ac8e47957c91a2a43e11e (diff)
parentacff6aa00473befac75f8120fc4299f4f265c258 (diff)
downloadpatches-288b8fd5e97c32d44a49612dbeef854c05ebc373.tar
patches-288b8fd5e97c32d44a49612dbeef854c05ebc373.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm57
1 files changed, 49 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 24bbbd347d..a0b59f3969 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3,7 +3,8 @@
;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
;;; Copyright © 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
@@ -85,6 +86,7 @@
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
+ #:use-module (gnu packages lisp)
#:use-module (gnu packages lua)
#:use-module (gnu packages markup)
#:use-module (gnu packages ncurses)
@@ -3881,13 +3883,13 @@ directory.")
(define-public r-htmlwidgets
(package
(name "r-htmlwidgets")
- (version "0.9")
+ (version "1.0")
(source (origin
(method url-fetch)
(uri (cran-uri "htmlwidgets" version))
(sha256
(base32
- "0plqkfqys1ca3ki7sb7yc6gwjpi7yy4g3mzh7hfy8s6qri0vam0i"))))
+ "09lkmzh35l1420sg0dyh4vgyishqx3g8xmgs2y9z7lbi09xgwwwr"))))
(build-system r-build-system)
(propagated-inputs
`(("r-htmltools" ,r-htmltools)
@@ -3904,26 +3906,24 @@ applications.")
(define-public r-htmltable
(package
(name "r-htmltable")
- (version "1.11.0")
+ (version "1.11.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "htmlTable" version))
(sha256
(base32
- "0x0qrzx6igg5z8jh901d2a8g2idpm5f4frwp1m02910scifcrxwf"))))
+ "1lbpi0kkk8b41w10scmlf27dg5azcv51a4q3p5bpqyphrnqp78k4"))))
(properties `((upstream-name . "htmlTable")))
(build-system r-build-system)
(propagated-inputs
`(("r-checkmate" ,r-checkmate)
- ("r-dplyr" ,r-dplyr)
("r-htmltools" ,r-htmltools)
("r-htmlwidgets" ,r-htmlwidgets)
("r-knitr" ,r-knitr)
("r-magrittr" ,r-magrittr)
("r-rstudioapi" ,r-rstudioapi)
- ("r-stringr" ,r-stringr)
- ("r-tidyr" ,r-tidyr)))
+ ("r-stringr" ,r-stringr)))
(home-page "http://gforge.se/packages/")
(synopsis "Advanced tables for Markdown/HTML")
(description
@@ -5418,6 +5418,47 @@ extensive prebuilt widgets make it possible to build beautiful,
responsive, and powerful applications with minimal effort.")
(license l:artistic2.0)))
+(define-public r-shinydashboard
+ (package
+ (name "r-shinydashboard")
+ (version "0.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "shinydashboard" version))
+ (sha256
+ (base32
+ "14zi7g5wrngy6lwi9xpvaid7727m6rfdijbb89al9likfhjqzqqy"))))
+ (build-system r-build-system)
+ ;; The directory inst/AdminLTE/ contains a minified JavaScript file.
+ ;; Regenerate it from the included sources.
+ (arguments
+ `(#:modules ((guix build utils)
+ (guix build r-build-system)
+ (ice-9 popen))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'generate-minified-javascript
+ (lambda _
+ (with-directory-excursion "inst/AdminLTE"
+ (delete-file "app.min.js")
+ (let ((minified (open-pipe* OPEN_READ "uglify-js" "app.js")))
+ (call-with-output-file "app.min.js"
+ (lambda (port)
+ (dump-port minified port))))))))))
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)
+ ("r-shiny" ,r-shiny)))
+ (native-inputs
+ `(("uglify-js" ,uglify-js)))
+ (home-page "http://rstudio.github.io/shinydashboard/")
+ (synopsis "Create dashboards with shiny")
+ (description "This package provides an extension to the Shiny web
+application framework for R, making it easy to create attractive dashboards.")
+ ;; This package includes software that was released under the Expat
+ ;; license, but the whole package is released under GPL version 2 or
+ ;; later.
+ (license l:gpl2+)))
+
(define-public r-crosstalk
(package
(name "r-crosstalk")