summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-08-29 17:19:18 -0400
committerMark H Weaver <mhw@netris.org>2019-08-29 17:19:18 -0400
commit0481289cbccba2646bf654f0ae49ac9c45602d5d (patch)
treecbe1351e2751e9d22c4c8add02991a3e6674f26a /gnu/packages/web.scm
parentc55fae452032aa4b1b63406983e9abdf70adc957 (diff)
parent9fbf4d2a52d4d3e01059f3432bb3f78182b5a822 (diff)
downloadpatches-0481289cbccba2646bf654f0ae49ac9c45602d5d.tar
patches-0481289cbccba2646bf654f0ae49ac9c45602d5d.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 065700465e..2008b8ee46 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -68,6 +68,7 @@
#:use-module (guix build-system python)
#:use-module (guix build-system ant)
#:use-module (guix build-system scons)
+ #:use-module (guix build-system go)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages adns)
@@ -92,6 +93,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnu-doc)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -6596,3 +6598,35 @@ It's also possible to rewrite existing log files.
Anonip can also be uses as a Python module in your own Python application.")
(license license:bsd-3)))
+
+(define-public poussetaches
+ (package
+ (name "poussetaches")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tsileo/poussetaches")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07106kfcz3a39jvrv3mlqqxlihsmdhgkrjnqznyjsij9absgvdv6"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ `(("go-github-com-robfig-cron" ,go-github-com-robfig-cron)
+ ("go-golang-org-x-time-rate" ,go-golang-org-x-time-rate)))
+ (arguments
+ `(#:import-path "github.com/tsileo/poussetaches"))
+ (home-page "https://github.com/tsileo/poussetaches")
+ (synopsis "Lightweight asynchronous task execution service")
+ (description "Poussetaches (which literally means \"push tasks\" in
+French) is a lightweight asynchronous task execution service that aims to
+replace Celery and RabbitMQ for small Python applications.
+
+The app posts base64-encoded payload to poussetaches and specifies the
+endpoint that will be used to trigger the task. Poussetaches makes HTTP
+requests with the registered payload until the right status code is
+returned.")
+ (license license:isc)))