summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 18:31:11 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-12 02:33:54 +0100
commit082504addf2e285d061cc02c5c4ba9c69cd2c153 (patch)
tree922bc86eaafcf499e0e722d5bae824ec34b0928b /gnu/packages/web.scm
parent20ab34c16f612df6ca02d25e2e357c37443cfd83 (diff)
downloadpatches-082504addf2e285d061cc02c5c4ba9c69cd2c153.tar
patches-082504addf2e285d061cc02c5c4ba9c69cd2c153.tar.gz
gnu: qjson: Don't use unstable tarball.
* gnu/packages/web.scm (qjson)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6578ce5137..84949ab0f9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -620,17 +620,17 @@ project)
(name "qjson")
(version "0.9.0")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/flavio/qjson/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/flavio/qjson.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1m0h4rajj99hv9w4i381a8x81lxiv167lxk10ncvphpkfxs624p8"))))
+ "1f4wnxzx0qdmxzc7hqk28m0sva7z9p9xmxm6aifvjlp0ha6pmfxs"))))
(build-system cmake-build-system)
(arguments
- ;; The tests require a X server
+ ;; The tests require a running X server.
`(#:configure-flags '("-DQJSON_BUILD_TESTS=ON"
"-DCMAKE_CXX_FLAGS=-std=gnu++11 -fPIC")
#:phases