summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-23 09:05:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 00:05:28 +0200
commitefc8f7d03d8c5857467fa14e85d5cdc267af58a7 (patch)
tree1b682399f86339621125c3d24040e3986f186f07 /gnu/packages/web.scm
parent9e88b210f660ae73c1eb39bb16538c5aff0a2bfc (diff)
downloadpatches-efc8f7d03d8c5857467fa14e85d5cdc267af58a7.tar
patches-efc8f7d03d8c5857467fa14e85d5cdc267af58a7.tar.gz
gnu: Add perl-lwp-online.
* gnu/packages/web.scm (perl-lwp-online): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0e6b95e599..686659ad78 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2891,6 +2892,35 @@ contains modules that are of more general use and even classes that
help you implement simple HTTP servers.")
(home-page "http://search.cpan.org/dist/libwww-perl/")))
+(define-public perl-lwp-online
+ (package
+ (name "perl-lwp-online")
+ (version "1.08")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/A/AD/ADAMK/LWP-Online-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "176f6vbk1018i0y7xj9d406ndbjgwzan2j9nihxnsahzg2vr2vz2"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-libwww" ,perl-libwww)
+ ("perl-uri" ,perl-uri)))
+ (native-inputs
+ `(("perl-module-install" ,perl-module-install)))
+ (home-page "http://search.cpan.org/dist/LWP-Online/")
+ (synopsis "Checks whether your process has access to the web")
+ (description "This module attempts to answer, as accurately as it can, one
+of the nastiest technical questions there is: am I on the internet?
+
+A host of networking and security issues make this problem very difficult.
+There are firewalls, proxies (both well behaved and badly behaved). We might
+not have DNS. We might not have a network card at all!")
+ (license l:perl-license)))
+
(define-public perl-lwp-mediatypes
(package
(name "perl-lwp-mediatypes")