summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
commit1c055d72585bd075e20ad0b41942d501d0b38656 (patch)
tree7baf50e22fb5f6c6d4b2fa7197596f68298eb691 /gnu/packages/web.scm
parent565e24c4e4710a5b81cce5cfb619b3e474e7f65c (diff)
parentffb4da7ad5c0e9cc969e0e47a3b8f4d2eba4d6f3 (diff)
downloadpatches-1c055d72585bd075e20ad0b41942d501d0b38656.tar
patches-1c055d72585bd075e20ad0b41942d501d0b38656.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a612be0130..0d2a247e12 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -775,14 +775,13 @@ used to validate and fix HTML data.")
;; For the log file, etc.
"--localstatedir=/var")
#:phases
- (alist-cons-before
- 'build 'pre-build
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- ;; Uncommenting the next two lines may assist in debugging
- ;; (substitute* "docs/man5/Makefile" (("a2x") "a2x -v"))
- ;; (setenv "XML_DEBUG_CATALOG" "1")
- #t)
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'build 'pre-build
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ ;; Uncommenting the next two lines may assist in debugging
+ ;; (substitute* "docs/man5/Makefile" (("a2x") "a2x -v"))
+ ;; (setenv "XML_DEBUG_CATALOG" "1")
+ #t)))))
;; All of the below are used to generate the documentation
;; (Should they be propagated inputs of asciidoc ??)
(native-inputs `(("asciidoc" ,asciidoc)))