summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-03-18 15:40:15 -0400
committerKei Kebreau <kei@openmailbox.org>2017-03-21 11:15:08 -0400
commit4b0e63670119971864289d67fc1e11a438f58ea6 (patch)
tree1244b9207324a64877c01cc3732d52e870fe72ae /gnu/packages/web.scm
parented428a58ec347a9fb48aa75d805fab665f0eb6f4 (diff)
downloadpatches-4b0e63670119971864289d67fc1e11a438f58ea6.tar
patches-4b0e63670119971864289d67fc1e11a438f58ea6.tar.gz
gnu: Adjust asciidoc-related build options.
Commits 9099a45792306fade2d9ca55138e49ef4f01f1ea and 3078821d1380c26c738be6b5d430c595327d401f make many package inputs and build configurations related to asciidoc obsolete. * gnu/packages/compton.scm (compton)[inputs]: Remove docbook-xml, libxml2 and libxslt. * gnu/packages/mail.scm (offlinemap)[native-inputs]: Remove libxslt. * gnu/packages/linux.scm (btrfs-progs)[native-inputs]: Remove docbook-xml. (perf)[inputs]: Remove docbook-xml and libxslt. * gnu/packages/text-editors.scm (kakoune)[native-inputs]: Remove libxslt. * gnu/packages/version-control.scm (cgit)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and libxslt. (cvs-fast-export)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and libxslt. * gnu/packages/web.scm (qutebrowser)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2, and libxslt. (tinyproxy)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and libxslt. * gnu/packages/wm.scm (awesome)[make-flags]: Remove XML_CATALOG_FILES flag. (i3-wm)[inputs]: Remove docbook-xml. [native-inputs]: Add libxml2.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a0e76d52c4..7fb94005e8 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -626,11 +626,7 @@ used to validate and fix HTML data.")
%standard-phases)))
;; All of the below are used to generate the documentation
;; (Should they be propagated inputs of asciidoc ??)
- (native-inputs `(("asciidoc" ,asciidoc)
- ("libxml2" ,libxml2)
- ("docbook-xml" ,docbook-xml)
- ("docbook-xsl" ,docbook-xsl)
- ("libxslt" ,libxslt)))
+ (native-inputs `(("asciidoc" ,asciidoc)))
(home-page "https://tinyproxy.github.io/")
(synopsis "Light-weight HTTP/HTTPS proxy daemon")
(description "Tinyproxy is a light-weight HTTP/HTTPS proxy
@@ -4479,11 +4475,7 @@ exploit attempts.")
"0pf91nc0xcykahc3x7ww525c9czm8zpg80nxl8n2mrzc4ilgvass"))))
(build-system python-build-system)
(native-inputs
- `(("asciidoc" ,asciidoc)
- ("docbook-xsl" ,docbook-xsl)
- ("docbook-xml" ,docbook-xml)
- ("libxml2" ,libxml2) ;for xmllint
- ("libxslt" ,libxslt))) ;for xsltproc
+ `(("asciidoc" ,asciidoc)))
(inputs
`(("python-colorama" ,python-colorama)
("python-cssutils" ,python-cssutils)