summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 18:58:23 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-12 02:33:54 +0100
commit3e3414efd45d95bbc6320fed75057cb2c82cc3af (patch)
treefc28316224e51353c36ad041b024420bf942d555 /gnu/packages/web.scm
parent082504addf2e285d061cc02c5c4ba9c69cd2c153 (diff)
downloadpatches-3e3414efd45d95bbc6320fed75057cb2c82cc3af.tar
patches-3e3414efd45d95bbc6320fed75057cb2c82cc3af.tar.gz
gnu: rapidjson: Don't use unstable tarball.
* gnu/packages/web.scm (rapidjson)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 84949ab0f9..7629353b72 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -747,14 +747,14 @@ current version of any major web browser.")
(name "rapidjson")
(version "1.1.0")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/miloyip/rapidjson/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/miloyip/rapidjson.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "13nrpvw8f1wx0ga7svbzld7pgrv8l172nangpipnj7jaf0lysz5z"))
+ "1jixgb8w97l9gdh3inihz7avz7i770gy2j2irvvlyrq3wi41f5ab"))
(modules '((guix build utils)))
(snippet
'(begin