summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-21 11:21:11 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-28 10:35:19 +0200
commitea5616e0e6fc5b86eafee487e5cbf77962950a2b (patch)
tree64b4f42a70bedca9876554fee1f28bafd219d580 /gnu/packages/web.scm
parent21d3770e0229fab69ec247760f37e03972484e54 (diff)
downloadpatches-ea5616e0e6fc5b86eafee487e5cbf77962950a2b.tar
patches-ea5616e0e6fc5b86eafee487e5cbf77962950a2b.tar.gz
gnu: Add r-servr.
* gnu/packages/web.scm (r-servr): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2184cc7c23..896105e7e9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2910,3 +2910,28 @@ and prettify JSON data. The unit tests included with the package verify that
all edge cases are encoded and decoded consistently for use with dynamic data
in systems and applications.")
(license l:expat)))
+
+(define-public r-servr
+ (package
+ (name "r-servr")
+ (version "0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "servr" version))
+ (sha256
+ (base32
+ "0gah99snaj8lk5zfzbxi3jwvpnlff9diz9gqv4qalfxpmb7fp6lc"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-httpuv" ,r-httpuv)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-mime" ,r-mime)))
+ (native-inputs
+ `(("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/yihui/servr")
+ (synopsis "Simple HTTP server to serve static files or dynamic documents")
+ (description
+ "Servr provides an HTTP server in R to serve static files, or dynamic
+documents that can be converted to HTML files (e.g., R Markdown) under a given
+directory.")
+ (license l:expat)))