summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-11-03 18:39:17 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2017-11-20 09:30:27 +0300
commit036f1eedcc46e50fda525a65eef5de1797ce4f4d (patch)
tree2c0a84b162d2df7825ba3bce66f4c4c8969d5307 /gnu/packages/web.scm
parent08cc0ef096ea37d0936b3e2ba2df693aaf52729a (diff)
downloadpatches-036f1eedcc46e50fda525a65eef5de1797ce4f4d.tar
patches-036f1eedcc46e50fda525a65eef5de1797ce4f4d.tar.gz
gnu: Add python-clf.
* gnu/packages/web.scm (python-clf): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8a6cd91ebc..a4a8778efa 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5212,6 +5212,58 @@ internetarchive python module for programatic access to archive.org.")
(package-with-python2
(strip-python2-variant python-internetarchive)))
+(define-public python-clf
+ (let ((commit-test-clf "d01d25923c599d3261910f79fb948825b4270d07")) ; 0.5.7
+ (package
+ (name "python-clf")
+ (version "0.5.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "clf" version))
+ (sha256
+ (base32
+ "0zlkzqnpz7a4iavsq5vaz0nf5nr7qm5znpg1vlpz6rwnx6hikjdb"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-docopt" ,python-docopt)
+ ("python-pygments" ,python-pygments)
+ ("python-requests" ,python-requests)
+ ("python-nose" ,python-nose)
+ ("python-lxml" ,python-lxml)
+ ("python-pyaml" ,python-pyaml)))
+ (inputs
+ `(("test-clf"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "https://raw.githubusercontent.com"
+ "/ncrocfer/clf/" commit-test-clf
+ "/test_clf.py"))
+ (sha256
+ (base32
+ "19lr5zdzsmxgkg7wrjq1yzkiahd03wi4k3dskssyhmjls8c10nqd"))))))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'get-tests
+ (lambda _
+ (copy-file (assoc-ref %build-inputs "test-clf") "test_clf.py")))
+ (replace 'check
+ (lambda _
+ (zero? (system* "nosetests"
+ ;; These tests require internet connection
+ "--exclude=test_browse"
+ "--exclude=test_command"
+ "--exclude=test_search")))))))
+ (home-page "https://github.com/ncrocfer/clf")
+ (synopsis "Search code snippets on @url{https://commandlinefu.com}")
+ (description "@code{clf} is a command line tool for searching code
+snippets on @url{https://commandlinefu.com}.")
+ (license l:expat))))
+
+(define-public python2-clf
+ (package-with-python2 python-clf))
+
(define-public r-shiny
(package
(name "r-shiny")