summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-12-03 18:58:19 +0100
committerLudovic Courtès <ludo@gnu.org>2019-12-09 18:32:04 +0100
commit4427417bd74c369162aff3ca51b37bc6313a6438 (patch)
treebeb5f7dd9d8c67f1ff60d5619e2ddfd9bf0f0050 /gnu/packages/web.scm
parent054ff198e446ae7b0a0dd183caf69368b8b9f580 (diff)
downloadpatches-4427417bd74c369162aff3ca51b37bc6313a6438.tar
patches-4427417bd74c369162aff3ca51b37bc6313a6438.tar.gz
gnu: websocketpp: Add patch for Boost >= 1.70.
* gnu/packages/patches/websocket-fix-for-boost-1.70.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/web.scm (websocketpp): Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 4c96422432..1fbd3dcb7a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1073,7 +1073,8 @@ other systems that want to manipulate WebAssembly files.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "12ffczcrryh74c1xssww35ic6yiy2l2xgdd30lshiq9wnzl2brgy"))))
+ (base32 "12ffczcrryh74c1xssww35ic6yiy2l2xgdd30lshiq9wnzl2brgy"))
+ (patches (search-patches "websocketpp-fix-for-boost-1.70.patch"))))
(build-system cmake-build-system)
(inputs `(("boost" ,boost)
("openssl" ,openssl)))