summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-01-02 23:33:12 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-01-13 01:25:15 +0100
commit304db09257b353a677440e3b3c94f08446015ed2 (patch)
tree051ba51df6505b07131da23b9d45096fff83e465 /gnu/packages/web.scm
parent9c2094785d5077d82b8f238e4d7aaf372e61fd06 (diff)
downloadpatches-304db09257b353a677440e3b3c94f08446015ed2.tar
patches-304db09257b353a677440e3b3c94f08446015ed2.tar.gz
gnu: http-parser: Download from git.
* gnu/packages/web.scm (http-parser)[source]: Change to GIT-FETCH.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d1713c7a0d..52da99ce2b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5075,14 +5075,15 @@ into your tests. It automatically starts up a HTTP server in a separate thread
(package
(name "http-parser")
(version "2.8.1")
+ (home-page "https://github.com/nodejs/http-parser")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/nodejs/http-parser/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "15ids8k2f0xhnnxh4m85w2f78pg5ndiwrpl24kyssznnp1l5yqai"))))
+ "0d2ni77pdw51n6qf0pq2gkc78i6yvnaw3nds6ldgmqqndzp2yv31"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -5093,7 +5094,6 @@ into your tests. It automatically starts up a HTTP server in a separate thread
#:phases
(modify-phases %standard-phases
(delete 'configure))))
- (home-page "https://github.com/nodejs/http-parser")
(synopsis "HTTP request/response parser for C")
(description "This is a parser for HTTP messages written in C. It parses
both requests and responses. The parser is designed to be used in