summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 18:14:54 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-12 02:33:54 +0100
commit20ab34c16f612df6ca02d25e2e357c37443cfd83 (patch)
treeabdd66367e9129ace11a514556a4782d063ac881 /gnu/packages/web.scm
parentbff44abb14fa8e411fa1fdc54e9115dda0e02fb6 (diff)
downloadpatches-20ab34c16f612df6ca02d25e2e357c37443cfd83.tar
patches-20ab34c16f612df6ca02d25e2e357c37443cfd83.tar.gz
gnu: fcgiwrap: Don't use unstable tarball.
* gnu/packages/web.scm (fcgiwrap)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7238987f5b..6578ce5137 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -413,16 +413,16 @@ APIs.")
(version "1.1.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/gnosek/fcgiwrap/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnosek/fcgiwrap.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "07y6s4mm86cv7p1ljz94sxnqa89y9amn3vzwsnbq5hrl4vdy0zac"))))
+ (base32 "1ryw66h9aazi83amk8l7ha8k5g0c7qvk5g6jv376a1ws9xk2qw6f"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests included
+ `(#:tests? #f ; no tests included
#:make-flags (list "CC=gcc")))
(native-inputs
`(("autoconf" ,autoconf)