summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-16 17:48:46 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-16 17:48:46 +0200
commit90b94761b673665e212e2677e5ed9924f9a6af42 (patch)
treecfee82335e98af3e0aeb88b59e06a6ebd157cc3b /gnu/packages/web.scm
parentb2c3640d2baa7bc929bf21880e6fb2785f5997f6 (diff)
downloadpatches-90b94761b673665e212e2677e5ed9924f9a6af42.tar
patches-90b94761b673665e212e2677e5ed9924f9a6af42.tar.gz
gnu: http-parser: Fix build on i686-linux.
Fixes a regression introduced in c11fcc6aa27db5f68aed807a6190143f4a156564, whereby 'http-parser' would fail to build on i686. * gnu/packages/web.scm (http-parser)[source](modules, snippet): New fields.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a164048641..2a982f417c 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5163,7 +5163,16 @@ into your tests. It automatically starts up a HTTP server in a separate thread
(file-name (git-file-name name version))
(sha256
(base32
- "12ilmjma6vmlm2kl23fx5pbi226x098gljgxpx3h2kmq8pg2lm28"))))
+ "12ilmjma6vmlm2kl23fx5pbi226x098gljgxpx3h2kmq8pg2lm28"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; There are signedness errors that trigger on 32-bit
+ ;; platforms that trigger, and '-Werror' leads to build
+ ;; failures.
+ (substitute* "Makefile"
+ (("-Werror") ""))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"