summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-05-17 02:43:15 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-05-17 03:05:55 +0200
commit8731a4aaffa7ff7b9378f8344ecbe75eeadce266 (patch)
tree47106963cd6fa14f719cc6ad5b6236967add952f /gnu/packages/web.scm
parent9c476e4db523b028c3699401df3d39927844c42e (diff)
downloadpatches-8731a4aaffa7ff7b9378f8344ecbe75eeadce266.tar
patches-8731a4aaffa7ff7b9378f8344ecbe75eeadce266.tar.gz
gnu: jq: Update sources.
* gnu/packages/web.scm (jq)[source]: Update sha256. Add snippet to remove newly-bundled onigurama.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d9e4cb0ded..08339d19c7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4038,14 +4038,20 @@ It uses the uwsgi protocol for all the networking/interprocess communications.")
(package
(name "jq")
(version "1.6")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/stedolan/jq"
- "/releases/download/jq-" version
- "/jq-" version ".tar.gz"))
- (sha256
- (base32
- "1a76f46a652i2g333kfvrl6mp2w7whf6h1yly519izg4y967h9cn"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/stedolan/jq"
+ "/releases/download/jq-" version
+ "/jq-" version ".tar.gz"))
+ (sha256
+ (base32 "0wmapfskhzfwranf6515nzmm84r7kwljgfs7dg6bjgxakbicis2x"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove bundled onigurama.
+ (delete-file-recursively "modules")
+ #t))))
(inputs
`(("oniguruma" ,oniguruma)))
(native-inputs