summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 04:16:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:32:48 +0200
commit5e869bde79fafe8d526a6cd2fe020a3a1f825056 (patch)
tree7d4331f2237604466f5cf50fc0e3b6da32df7bbb /gnu/packages/web.scm
parent0437c682f59f3baef6ce7257ea8babf73e9e01ee (diff)
downloadpatches-5e869bde79fafe8d526a6cd2fe020a3a1f825056.tar
patches-5e869bde79fafe8d526a6cd2fe020a3a1f825056.tar.gz
gnu: Add python-httpretty.
* gnu/packages/web.scm (python-httpretty): New public variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ff26314447..7af2f63841 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5155,6 +5155,36 @@ Depending on your architecture, it only requires about 40 bytes of data per
message stream (in a web server that is per connection).")
(license l:expat)))
+(define-public python-httpretty
+ (package
+ (name "python-httpretty")
+ (version "0.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "httpretty" version))
+ (sha256
+ (base32 "1p1rb4mpngh0632xrmdfhvc8yink519yfkqz97d2ww3y0x2jvd81"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-httplib2" ,python-httplib2)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)
+ ("python-nose-randomly" ,python-nose-randomly)
+ ("python-rednose" ,python-rednose)
+ ("python-requests" ,python-requests)
+ ("python-sure" ,python-sure)
+ ("python-tornado" ,python-tornado)
+ ("python-urllib3" ,python-urllib3)))
+ (home-page "https://httpretty.readthedocs.io")
+ (synopsis "HTTP client mock for Python")
+ (description "@code{httpretty} is a helper for faking web requests,
+inspired by Ruby's @code{fakeweb}.")
+ (license l:expat)))
+
(define-public python2-httpretty
(package
(name "python2-httpretty")