summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-10 20:50:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-10 20:50:02 +0100
commit50b99c90c87642f664f9c9523a6e40fc8542ddcf (patch)
tree9fc8845e93ba913730e5fb92bbad158716d84e74 /gnu/packages/web-browsers.scm
parentbda4b5e0453e4c8feda24306b4aa76ad5406eb7d (diff)
parent21656ffa3b6d78a610f0befced20cc9b4b3baab6 (diff)
downloadpatches-50b99c90c87642f664f9c9523a6e40fc8542ddcf.tar
patches-50b99c90c87642f664f9c9523a6e40fc8542ddcf.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 88b74f6cd7..0a7deb5d17 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -575,7 +575,17 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
(format #t "~a" ,(package-version next-gtk-webkit))))
(invoke "make" "install-assets"
(string-append "PREFIX="
- (assoc-ref outputs "out"))))))))
+ (assoc-ref outputs "out")))))
+ (add-after 'unpack 'fix-lambda-list
+ ;; Starting from SBCL 2.0.2, Next 1.5.0 won't build
+ ;; because of a weird lambda list type.
+ (lambda _
+ (substitute* "source/keymap.lisp"
+ (("^\\(declaim .* define-key\\)\\)") ""))
+ (substitute* "source/search-buffer.lisp"
+ (("define-key :keymap keymap \"C-s\"") "define-key \"C-s\"")
+ (("\\(update-selection-highlight-hint :follow t :scroll t\\)\\)\\)")
+ "(update-selection-highlight-hint :follow t :scroll t)) :keymap keymap)")))))))
(inputs
`(("alexandria" ,sbcl-alexandria)
("bordeaux-threads" ,sbcl-bordeaux-threads)