summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-05-08 12:21:30 -0400
committerKei Kebreau <kei@openmailbox.org>2017-05-08 15:07:48 -0400
commit8bdc36d4bd5d38a5e595c9c51e61bad4caf291e0 (patch)
tree91123fa7c1565ca8c0c682c1b820050b40ba0d84 /gnu/packages/web-browsers.scm
parent65584b91c7029e93e6fd207f08c958206f1dcfc5 (diff)
downloadpatches-8bdc36d4bd5d38a5e595c9c51e61bad4caf291e0.tar
patches-8bdc36d4bd5d38a5e595c9c51e61bad4caf291e0.tar.gz
gnu: Move links to web-browsers.scm.
* gnu/packages/links.scm: Remove file and move links... * gnu/packages/web-browsers.scm: ...here. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove links.scm.
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 07b61dd25e..4cbd5fbe06 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -1,4 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;;
@@ -25,6 +27,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -67,6 +70,57 @@ older or slower computers and embedded systems.")
(home-page "http://www.dillo.org")
(license license:gpl3+)))
+(define-public links
+ (package
+ (name "links")
+ (version "2.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://links.twibright.com/download/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1f24y83wa1vzzjq5kp857gjqdpnmf8pb29yw7fam0m8wxxw0c3gp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; The tarball uses a very old version of autconf. It doesn't
+ ;; understand extra flags like `--enable-fast-install', so
+ ;; we need to invoke it with just what it understands.
+ (let ((out (assoc-ref outputs "out")))
+ ;; 'configure' doesn't understand '--host'.
+ ,@(if (%current-target-system)
+ `((setenv "CHOST" ,(%current-target-system)))
+ '())
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" out)
+ "--enable-graphics"))))))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("zlib" ,zlib)
+ ("openssl" ,openssl)
+ ("libjpeg" ,libjpeg)
+ ("libtiff" ,libtiff)
+ ("libevent" ,libevent)
+ ("libpng" ,libpng)
+ ("libxt" ,libxt)))
+ (synopsis "Text and graphics mode web browser")
+ (description "Links is a graphics and text mode web browser, with many
+features including, tables, builtin image display, bookmarks, SSL and more.")
+ (home-page "http://links.twibright.com")
+ ;; The distribution contains a copy of GPLv2
+ ;; However, the copyright notices simply say:
+ ;; "This file is a part of the Links program, released under GPL."
+ ;; Therefore, under the provisions of Section 9, we can choose
+ ;; any version ever published by the FSF.
+ ;; One file (https.c) contains an exception permitting
+ ;; linking of the program with openssl.
+ (license license:gpl1+)))
+
(define-public qutebrowser
(package
(name "qutebrowser")