summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-26 20:26:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-27 22:26:17 +0200
commitaad2dbfb6ca80085e9d96417262177d8d9c6718b (patch)
treeedef61b47c000194e3c9ea973c9cf92c216cffa5 /gnu/packages/vim.scm
parentb200ecdeb2ba97bcaeec04a4da5e31736f00a5ea (diff)
downloadpatches-aad2dbfb6ca80085e9d96417262177d8d9c6718b.tar
patches-aad2dbfb6ca80085e9d96417262177d8d9c6718b.tar.gz
gnu: Add vim-fugitive.
* gnu/packages/vim.scm (vim-fugitive): New variable.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 0163662d10..85ccf9c9d1 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -440,6 +440,46 @@ trouble using them, because you do not have to remember each snippet name.")
(home-page "https://github.com/Shougo/context_filetype.vim")
(license license:expat)))) ; ??? check again
+;; The 2.2 release was in 2015, no new releases planned.
+(define-public vim-fugitive
+ (let ((commit "de6c05720cdf74c0218218d7207f700232a5b6dc")
+ (revision "1"))
+ (package
+ (name "vim-fugitive")
+ (version (string-append "2.2-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tpope/vim-fugitive.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0zg9vv7hirnx45vc2mwgg0xijmwwz55bssyd6cpdz71wbhrcpxxb"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (vimfiles (string-append out "/share/vim/vimfiles"))
+ (doc (string-append vimfiles "/doc"))
+ (plugin (string-append vimfiles "/plugin")))
+ (copy-recursively "doc" doc)
+ (copy-recursively "plugin" plugin)
+ #t))))))
+ (home-page "https://github.com/tpope/vim-fugitive")
+ (synopsis "Vim plugin to work with Git")
+ (description "Vim-fugitive is a wrapper for Vim that complements the
+command window, where you can stage and review your changes before the next
+commit or run any Git arbitrary command.")
+ (license license:vim)))) ; distributed under the same license as vim
+
(define-public vim-airline
(package
(name "vim-airline")