summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2019-03-06 21:51:57 +0100
committerGábor Boskovits <boskovits@gmail.com>2019-03-07 11:08:31 +0100
commit0a10abf73e7bb1d5f751229c709903a0f66574d2 (patch)
treeda0f3a4abe55c43bb55ccfc9af409e5082b2a9e5 /gnu/packages/vim.scm
parent2702aa913648b308a4fdac0b2b27b722894265ed (diff)
downloadpatches-0a10abf73e7bb1d5f751229c709903a0f66574d2.tar
patches-0a10abf73e7bb1d5f751229c709903a0f66574d2.tar.gz
gnu: neovim: Fix #34616.
This fixes a segmentation fault in neovim, where an error return value is passed in as a pointer. * gnu/packages/vim.scm (neovim)[arguments](phases): Add 'patch-tic phase.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 5e1e9b852c..a6f4395f53 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -693,6 +693,12 @@ are detected, the user is notified.")))
#:configure-flags '("-DPREFER_LUA:BOOL=YES")
#:phases
(modify-phases %standard-phases
+ ;; TODO: remove 'patch-tic on update
+ ;; see: https://github.com/neovim/neovim/issues/9687
+ (add-after 'unpack 'patch-tic
+ (lambda _
+ (substitute* "src/nvim/tui/tui.c"
+ (("value != NULL") "value != NULL && value != (char *)-1"))))
(add-after 'unpack 'set-lua-paths
(lambda* (#:key inputs #:allow-other-keys)
(let* ((lua-version "5.2")