summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-21 22:16:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-21 22:16:02 +0100
commitd19b14c8349ce8cacb62619ab68953265daeeca7 (patch)
tree9aacc6f9378ca69951c87232b3a7526fef2f2054 /gnu/packages/video.scm
parent680b56116a4840a281a45cb130fd45d6d3d46c56 (diff)
parentee4c927f33a1d3b01cf36be3c74227f6b7fd69ff (diff)
downloadpatches-d19b14c8349ce8cacb62619ab68953265daeeca7.tar
patches-d19b14c8349ce8cacb62619ab68953265daeeca7.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 861e5c427e..e90650b5eb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -922,6 +922,8 @@ operate properly.")
(method url-fetch)
(uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
version ".tar.xz"))
+ ;; See <https://issues.guix.gnu.org/issue/39719>
+ (patches (search-patches "ffmpeg-prefer-dav1d.patch"))
(sha256
(base32
"176jn1lcdf0gk7sa5l2mv0faqp5dsqdhx1gqcrgymqhfmdal4xfb"))))
@@ -1204,6 +1206,10 @@ videoformats depend on the configuration flags of ffmpeg.")
(inputs
`(("alsa-lib" ,alsa-lib)
("avahi" ,avahi)
+ ;; XXX Try removing dav1d here and testing AV1 playback when FFmpeg 4.3
+ ;; is released.
+ ;; <https://issues.guix.gnu.org/issue/39719>
+ ("dav1d" ,dav1d)
("dbus" ,dbus)
("eudev" ,eudev)
("flac" ,flac)