summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-29 16:13:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-29 22:43:48 +0100
commitd61236dffd7e6d58aebe08570d6a67b4bb5536d8 (patch)
treed2e2817c269c3fcbad804d620ce29e24fabc37cf /gnu/packages/video.scm
parentde1830ae6d0a2c33445f20d25c7f8ff6a290c31d (diff)
downloadpatches-d61236dffd7e6d58aebe08570d6a67b4bb5536d8.tar
patches-d61236dffd7e6d58aebe08570d6a67b4bb5536d8.tar.gz
gnu: vidstab: Fetch sources from git.
* gnu/packages/video.scm (vidstab)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0d31caed19..b36eafc711 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3126,12 +3126,14 @@ online.")
(name "vidstab")
(version "1.1.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/georgmartius/vid.stab/"
- "archive/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/georgmartius/vid.stab.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1fy03n343djfdi19msac81833v5iivpv635yjzrx9nkfwm9s1lhl"))))
+ "0a3frpm2kdbx7vszhg64p3alisag73bcspl7fp3a2f1kgq7rbh38"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ; tests are not run as part of standard build process