summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-29 21:45:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-29 22:43:48 +0100
commit97ef6df5ecec825712c1253551d5be1ab7d89b06 (patch)
tree51645e8c222029b5161ec7ab9827500585cd6e34 /gnu/packages/video.scm
parent5d9e3edd013d245a413543d10ab64f66e1bd2717 (diff)
downloadpatches-97ef6df5ecec825712c1253551d5be1ab7d89b06.tar
patches-97ef6df5ecec825712c1253551d5be1ab7d89b06.tar.gz
gnu: vapoursynth: Fetch sources from git.
* gnu/packages/video.scm (vapoursynth)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 496b3277c5..a10551e41b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1854,14 +1854,14 @@ capabilities.")
(name "vapoursynth")
(version "37")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/vapoursynth/vapoursynth/archive/R"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vapoursynth/vapoursynth.git")
+ (commit (string-append "R" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1g3hc079jw4mz1cmkv2y28pdb556wqc8ql7iravgh1rg8j3f1zi5"))))
+ "1ma2s7dxk6y6l04qj1jvgwia4xj7999ny3a1yx2vbk5l83giam2p"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)