summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-08-21 16:46:50 -0400
committerLeo Famulari <leo@famulari.name>2019-08-22 11:49:02 -0400
commitad64f271de2737c40571c413845548c61a2462e3 (patch)
tree8658e5ba51652f5518075ed681ea1aee44910259 /gnu/packages/video.scm
parentf5111b4d2b982d58387188bc3018e4dd2e9a9d4f (diff)
downloadpatches-ad64f271de2737c40571c413845548c61a2462e3.tar
patches-ad64f271de2737c40571c413845548c61a2462e3.tar.gz
gnu: vidstab: Update to 1.1.0-0.aeabc8d.
* gnu/packages/video.scm (vidstab): Update to 1.1.0-0.aeabc8d.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm40
1 files changed, 21 insertions, 19 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8b7bb38fa8..dfb28a9309 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3373,30 +3373,32 @@ online.")
(license license:expat)))
(define-public vidstab
- (package
- (name "vidstab")
- (version "1.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/georgmartius/vid.stab.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0a3frpm2kdbx7vszhg64p3alisag73bcspl7fp3a2f1kgq7rbh38"))))
- (build-system cmake-build-system)
- (arguments
- '(#:tests? #f)) ; tests are not run as part of standard build process
- (home-page "http://public.hronopik.de/vid.stab/")
- (synopsis "Video stabilization library")
- (description "Vidstab is a video stabilization library which can be used
+ (let ((commit "aeabc8daa7904f9edf7441a11f293965a5ef53b8")
+ (revision "0"))
+ (package
+ (name "vidstab")
+ (version (git-version "1.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/georgmartius/vid.stab.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "042iy0f3khwzr68djzvqgn301sy21ljvkf52rnc2c73q7ircnzzn"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; tests are not run as part of standard build process
+ (home-page "http://public.hronopik.de/vid.stab/")
+ (synopsis "Video stabilization library")
+ (description "Vidstab is a video stabilization library which can be used
with FFmpeg. A video acquired using a hand-held camera or a camera mounted on a
vehicle typically suffers from undesirable shakes and jitters. Activities such
as surfing, skiing, riding and walking while shooting videos are especially
prone to erratic camera shakes. Vidstab targets these video contents to help
create smoother and stable videos.")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public libopenshot
(package