summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2019-02-11 12:53:05 +0100
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2019-02-13 10:23:22 +0100
commitf6974e15cfce8128d9a3fb425671b1f6fc05e49b (patch)
tree060b6b3a6824f6654616d052ece579c5a7358ef5 /gnu/packages/video.scm
parentf6f4370feeee27f26f151d47d2568ea144d52d3f (diff)
downloadpatches-f6974e15cfce8128d9a3fb425671b1f6fc05e49b.tar
patches-f6974e15cfce8128d9a3fb425671b1f6fc05e49b.tar.gz
gnu: Fix aegisub.
* gnu/packages/video.scm (aegisub)[arguments]: Add phase to fix boost headers.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 871d3e15d6..aa7930aad7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2877,7 +2877,17 @@ programmers to access a standard API to open and decompress media files.")
(add-before 'configure 'fix-ldflags
(lambda _
(setenv "LDFLAGS" "-pthread")
- #t)))))
+ #t))
+ (add-after 'unpack 'fix-boost-headers
+ (lambda _
+ (substitute*
+ '("src/subtitles_provider_libass.cpp"
+ "src/colour_button.cpp"
+ "src/video_provider_dummy.cpp"
+ "./src/video_frame.cpp")
+ (("#include <boost/gil/gil_all.hpp>")
+ "#include <boost/gil.hpp>"))
+ #t)))))
(inputs
`(("boost" ,boost)
("desktop-file-utils" ,desktop-file-utils)