summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-07-26 05:14:37 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-07-27 23:25:22 +0200
commit3563220e1e46b8a1b9af1e3a4c6cb3f9560c2460 (patch)
tree419e558bf444a821f2cc092496df55c5afd5fca6 /gnu/packages/video.scm
parentd8d7565b82539bfff721bf884b7f4a3de3e6b4c3 (diff)
downloadpatches-3563220e1e46b8a1b9af1e3a4c6cb3f9560c2460.tar
patches-3563220e1e46b8a1b9af1e3a4c6cb3f9560c2460.tar.gz
gnu: Add libva-utils.
* gnu/packages/video.scm (libva-utils): New public variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 5083b05a2e..51ff7fa97a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -753,6 +753,40 @@ entry-points (VLD, IDCT, Motion Compensation etc.) for prevailing coding
standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
(license license:expat)))
+(define-public libva-utils
+ (package
+ (name "libva-utils")
+ (version "2.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/intel/libva-utils/releases/download/"
+ version "/libva-utils-" version ".tar.bz2"))
+ (sha256
+ (base32 "05rasyqnsg522zqxak1q8rrm1hys7wwbi41kd0szjq0d27awjf4j"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--enable-wayland"
+ "--enable-x11")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libdrm" ,libdrm)
+ ("libva" ,libva)
+ ("libx11" ,libx11)
+ ("mesa" ,mesa)
+ ("wayland" ,wayland)))
+ (home-page "https://01.org/linuxmedia/vaapi")
+ (synopsis "Collection of testing utilities for VA-API")
+ (description
+ "This is a collection of utilities to query and test the @acronym{VA-API,
+Video Acceleration API} implemented by the libva library.
+
+These tools require a supported graphics chip, driver, and VA-API back end to
+operate properly.")
+ (license license:expat)))
+
(define-public ffmpeg
(package
(name "ffmpeg")