summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2016-09-09 15:52:26 -0400
committerLudovic Courtès <ludo@gnu.org>2016-09-13 10:26:35 +0200
commit6c0cd765c03de72ecd97b9222bff04c525b8bba4 (patch)
tree67b7869bef2383ef2bfa8eec5ffda8eca53b18cc /gnu/packages/video.scm
parent8dd6fc5164a00a70e1080d4a99998a4a65df4a89 (diff)
downloadpatches-6c0cd765c03de72ecd97b9222bff04c525b8bba4.tar
patches-6c0cd765c03de72ecd97b9222bff04c525b8bba4.tar.gz
gnu: libbluray: Enable libaacs and libbdplus support.
* gnu/packages/video.scm (libbluray) [inputs]: Add libaacs and libbdplus. [arguments]: Add 'fix-dlopen-paths' to #:phases. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7c1dae0799..6c59fa0fca 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -978,11 +978,27 @@ YouTube.com and a few more sites.")
(base32
"1q1whviqv5sr9nr372h31zwid1rvbfbx3z4lzr8lnj25xha6cdm6"))))
(build-system gnu-build-system)
- (arguments `(#:configure-flags '("--disable-bdjava")))
+ (arguments
+ `(#:configure-flags '("--disable-bdjava")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-dlopen-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libaacs (assoc-ref inputs "libaacs"))
+ (libbdplus (assoc-ref inputs "libbdplus")))
+ (substitute* "src/libbluray/disc/aacs.c"
+ (("\"libaacs\"")
+ (string-append "\"" libaacs "/lib/libaacs\"")))
+ (substitute* "src/libbluray/disc/bdplus.c"
+ (("\"libbdplus\"")
+ (string-append "\"" libbdplus "/lib/libbdplus\"")))
+ #t))))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs
`(("fontconfig" ,fontconfig)
("freetype" ,freetype)
+ ("libaacs" ,libaacs)
+ ("libbdplus" ,libbdplus)
("libxml2" ,libxml2)))
(home-page "https://www.videolan.org/developers/libbluray.html")
(synopsis "Blu-Ray Disc playback library")