summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-12-14 14:34:55 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-12-15 16:21:19 +0100
commit97115892b9661e396afddc515e7f8f948167f0c5 (patch)
treefa1e3649b58460eac2461cd927a04958fca4ec63 /gnu/packages/video.scm
parent614a1e3fa2d731d4719f03912b1b87fb4fd309cb (diff)
downloadpatches-97115892b9661e396afddc515e7f8f948167f0c5.tar
patches-97115892b9661e396afddc515e7f8f948167f0c5.tar.gz
gnu: Add theorafile.
* gnu/packages/video.scm (theorafile): New variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm41
1 files changed, 40 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3280114878..ef60767236 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -24,7 +24,7 @@
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
@@ -3677,3 +3677,42 @@ user interface features a builtin video player and is designed with attention
to convenience of translating and batch processing of multiple documents.")
(home-page "https://otsaloma.io/gaupol/")
(license license:gpl3+)))
+
+(define-public theorafile
+ (let ((commit "404b14d7602b5918d117eaa64e8aa6601ede8593"))
+ (package
+ (name "theorafile")
+ (version (git-version "0.0.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FNA-XNA/Theorafile.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "128c3pjzqbgrj020glm5jd6ss18vl19471lj615w2brjwb7c1f0z"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'check
+ (lambda _
+ (setenv "CC" "gcc")
+ (invoke "make" "test")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "libtheorafile.so" (string-append out "/lib"))
+ (install-file "theorafile.h" (string-append out "/include")))
+ #t)))))
+ (native-inputs
+ ;; For tests.
+ `(("sdl2" ,sdl2)))
+ (home-page "https://github.com/FNA-XNA/Theorafile")
+ (synopsis "Ogg Theora Video Decoder Library")
+ (description "Theorafile is a library for quickly and easily decoding Ogg
+Theora videos. Theorafile was written to be used for FNA's VideoPlayer.")
+ (license license:zlib))))