summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-04 23:08:52 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-05 11:52:41 +0800
commit6b2c6be0c3854e98e2cd9e81a3fea44f294ff086 (patch)
tree6875035af02bc209a985fb999bded9d7ca7682f3 /gnu/packages/video.scm
parent01b90919ef21b52905fa4f36d35a1631b9610612 (diff)
downloadpatches-6b2c6be0c3854e98e2cd9e81a3fea44f294ff086.tar
patches-6b2c6be0c3854e98e2cd9e81a3fea44f294ff086.tar.gz
gnu: Add aalib.
* gnu/packages/video.scm (aalib): New variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c6eb859bbb..58263f0826 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -66,6 +66,7 @@
#:use-module (gnu packages samba)
#:use-module (gnu packages sdl)
#:use-module (gnu packages ssh)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages texlive)
#:use-module (gnu packages textutils)
#:use-module (gnu packages version-control)
@@ -77,6 +78,44 @@
#:use-module (gnu packages yasm)
#:use-module (gnu packages zip))
+(define-public aalib
+ (package
+ (name "aalib")
+ (version "1.4rc5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/aa-project/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vkh19gb76agvh4h87ysbrgy82hrw88lnsvhynjf4vng629dmpgv"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("makeinfo" ,texinfo)))
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; This old `configure' script doesn't support
+ ;; variables passed as arguments.
+ (let ((out (assoc-ref outputs "out"))
+ (ncurses (assoc-ref inputs "ncurses")))
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (zero? (system* "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--with-ncurses="
+ ncurses)))))))))
+ (home-page "http://aa-project.sourceforge.net/aalib/")
+ (synopsis "ASCII-art library")
+ (description
+ "AA-lib is a low level gfx library which does not require graphics device.
+In fact, there is no graphical output possible. AA-lib replaces those
+old-fashioned output methods with powerful ascii-art renderer.")
+ (license license:lgpl2.0+)))
+
(define-public liba52
(package
(name "liba52")