summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-30 12:17:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-03-30 12:17:33 +0200
commitae0badf5bb791428423a98d4e4e2b8d297a5d4be (patch)
tree4282d243db3e90839a5f7d3b5878674ccd0e2e14 /gnu/packages/video.scm
parentee401ed9249fbe284ef1b9b437d39207ca88131b (diff)
parent927f3655662b41f25225ea03baa3ded687aa7cbb (diff)
downloadpatches-ae0badf5bb791428423a98d4e4e2b8d297a5d4be.tar
patches-ae0badf5bb791428423a98d4e4e2b8d297a5d4be.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/packages/admin.scm gnu/packages/commencement.scm gnu/packages/guile.scm gnu/packages/linux.scm gnu/packages/package-management.scm gnu/packages/pulseaudio.scm gnu/packages/web.scm
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 112c7c31e2..23533dfdbf 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1640,7 +1640,7 @@ To load this plugin, specify the following option when starting mpv:
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2020.03.08")
+ (version "2020.03.24")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ytdl-org/youtube-dl/"
@@ -1648,7 +1648,7 @@ To load this plugin, specify the following option when starting mpv:
version ".tar.gz"))
(sha256
(base32
- "1xbka14wnalcqkhibfcqw8f5bw1m9b1f44719yifv1jk0614q4bn"))))
+ "05l4asakakxn53wrvxn6c03fd80zdizdbj6r2cj8c1ja3sj9i8s5"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion
@@ -1860,6 +1860,8 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
`(#:modules ((guix build perl-build-system)
(guix build utils)
(srfi srfi-26))
+ ;; gtk-2/3 variants are both installed by default but the gtk3 variant
+ ;; is broken without perl-gtk3.
#:module-build-flags '("--gtk2")
#:phases
(modify-phases %standard-phases
@@ -2209,7 +2211,7 @@ capabilities.")
(define-public vapoursynth
(package
(name "vapoursynth")
- (version "48")
+ (version "49")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2218,7 +2220,7 @@ capabilities.")
(file-name (git-file-name name version))
(sha256
(base32
- "1i6163bidlp0p9zcnxpsphr44ayfzd51fig4ri7vbrbl9lw9jaih"))))
+ "1d298mlb24nlc2x7pixfbkd0qbpv4c706c32idsgpi96z1spkhvl"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -2309,9 +2311,6 @@ and custom quantization matrices.")
from sites like Twitch.tv and pipes them into a video player of choice.")
(license license:bsd-2)))
-(define-public livestreamer
- (deprecated-package "livestreamer" streamlink))
-
(define-public twitchy
(let ((commit "9beb36d80b16662414129693e74fa3a2fd97554e")) ; 3.4 has no tag
(package