summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-18 19:41:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-18 19:41:08 +0100
commitc4d769d359c67680fe55c3b71e659cd31837f3ec (patch)
tree928fe50be266c8975f4abad56e07ce4ebaef55fe /gnu/packages/version-control.scm
parentde2871c9faa44ee07f73470441f05d114a43bb48 (diff)
parent4de63cf3fc0a831d75cb507456821104f24800c2 (diff)
downloadpatches-c4d769d359c67680fe55c3b71e659cd31837f3ec.tar
patches-c4d769d359c67680fe55c3b71e659cd31837f3ec.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm93
1 files changed, 57 insertions, 36 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 27c7804029..c0f8130de4 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1048,9 +1048,6 @@ with performance and scalability in mind. It operates exclusively on streams,
allowing to handle large objects with a small memory footprint.")
(license license:bsd-3)))
-(define-public python2-gitdb
- (package-with-python2 python-gitdb))
-
(define-public python-gitpython
(package
(name "python-gitpython")
@@ -1092,9 +1089,6 @@ either a pure Python implementation, or the faster, but more resource intensive
@command{git} command implementation.")
(license license:bsd-3)))
-(define-public python2-gitpython
- (package-with-python2 python-gitpython))
-
(define-public shflags
(package
(name "shflags")
@@ -2100,36 +2094,6 @@ supports a large number of version control systems: Git, Subversion,
Mercurial, Bazaar, Darcs, CVS, Fossil, and Veracity.")
(license license:gpl2+)))
-(define-public git-annex-remote-hubic
- (package
- (name "git-annex-remote-hubic")
- (version "0.3.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Schnouki/git-annex-remote-hubic.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "16y9sk67hfi17h9n2kkffyabfccksh5rab40hhk69v6cxmbpn2sx"))))
- (build-system python-build-system)
- (arguments `(#:python ,python-2))
- (native-inputs
- `(;; for the tests
- ("python2-six" ,python2-six)))
- (propagated-inputs
- `(("python2-dateutil" ,python2-dateutil)
- ("python2-futures" ,python2-futures)
- ("python2-rauth" ,python2-rauth)
- ("python2-swiftclient" ,python2-swiftclient)))
- (home-page "https://github.com/Schnouki/git-annex-remote-hubic/")
- (synopsis "Use hubic as a git-annex remote")
- (description
- "This package allows you to use your hubic account as a \"special
-repository\" with git-annex.")
- (license license:gpl3+)))
-
(define-public git-annex-remote-rclone
(package
(name "git-annex-remote-rclone")
@@ -2474,3 +2438,60 @@ interrupted, published, and collaborated on while in progress.")
videos, datasets, and graphics with text pointers inside Git, while storing the
file contents on a remote server.")
(license license:expat)))
+
+(define-public tla
+ (package
+ (name "gnu-arch")
+ (version "1.3.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ftp.gnu.org/old-gnu/gnu-arch/"
+ "tla-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01mfzj1i6p4s8191cgd5850hds1zls88hkf9rb6qx1vqjv585aj0"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; In tar 1.32, '--preserve' is ambiguous and leads to an
+ ;; error, so address that.
+ (substitute* "src/tla/libarch/archive.c"
+ (("\"--preserve\"")
+ "\"--preserve-permissions\""))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (chdir "src")
+
+ (mkdir "=build")
+ (chdir "=build")
+
+ ;; For libneon's 'configure' script.
+ ;; XXX: There's a bundled copy of neon.
+ (setenv "CONFIG_SHELL" (which "sh"))
+
+ (invoke "../configure" "--prefix" out
+ "--config-shell" (which "sh")
+ "--with-posix-shell" (which "sh")
+ "--with-cc" "gcc")))))
+
+
+ ;; There are build failures when building in parallel.
+ #:parallel-build? #f
+ #:parallel-tests? #f
+
+ #:test-target "test"))
+ (native-inputs
+ `(("which" ,which)))
+ (synopsis "Historical distributed version-control system")
+ (description
+ "GNU Arch, aka. @code{tla}, was one of the first free distributed
+version-control systems (DVCS). It saw its last release in 2006. This
+package is provided for users who need to recover @code{tla} repositories and
+for historians.")
+ (home-page "https://www.gnu.org/software/gnu-arch/")
+ (license license:gpl2))) ;version 2 only