summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-30 20:27:21 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:53:57 +0200
commit395ee951c070ae8e9c039cfe3ee53413f602e923 (patch)
tree946b7315d07e5a3da4d10dfda0bbf8684171c295 /gnu/packages/version-control.scm
parent6a8472d1d982c9ef8ba623cc6546adf894601fab (diff)
downloadpatches-395ee951c070ae8e9c039cfe3ee53413f602e923.tar
patches-395ee951c070ae8e9c039cfe3ee53413f602e923.tar.gz
gnu: findnewest: Don't use unstable tarball.
* gnu/packages/version-control.scm (findnewest)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 45413de579..a388b9e97e 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1763,14 +1763,15 @@ output of the @code{git} command.")
(package
(name "findnewest")
(version "0.3")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/0-wiz-0/findnewest/archive/findnewest-"
- version ".tar.gz"))
- (sha256
- (base32
- "1ydis4y0amkgfr4y60sn076f1l41ya2kn89kfd9fqf44f9ccgb5r"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/0-wiz-0/findnewest.git")
+ (commit (string-append "findnewest-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1x1cbn2b27h5r0ah5xc06fkalfdci2ngrgd4wibxjw0h88h0nvgq"))))
(build-system gnu-build-system)
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)))