aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-14 10:45:01 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-14 10:45:01 +0200
commitaae4ead8142d4fd7c674a1e6e302f40469f878c6 (patch)
tree022987d73c705ca882e50c8a63b578c658a72de6 /gnu/packages/version-control.scm
parent29479de5659ba912b486c74078403bbb9a4df104 (diff)
parent2875caf5b52340ea16965b1d8f76342cc07bf8b5 (diff)
downloadpatches-aae4ead8142d4fd7c674a1e6e302f40469f878c6.tar
patches-aae4ead8142d4fd7c674a1e6e302f40469f878c6.tar.gz
Merge branch 'python'
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 14404f0bfe..42b5d5fe99 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -58,7 +58,9 @@
;; require Zsh.
`(("gettext" ,guix:gettext)))
(arguments
- `(#:tests? #f)) ; no test target
+ `(#:tests? #f ; no test target
+ #:python ,python-2)) ; Python 3 apparently not yet supported, see
+ ; https://answers.launchpad.net/bzr/+question/229048
(home-page "https://gnu.org/software/bazaar")
(synopsis "Decentralized revision control system")
(description
@@ -86,7 +88,7 @@ from a command line or use a GUI application.")
("gettext" ,guix:gettext)
("openssl" ,openssl)
("perl" ,perl)
- ("python" ,python) ; CAVEAT: incompatible with python-3 according to INSTALL
+ ("python" ,python-2) ; CAVEAT: incompatible with python-3 according to INSTALL
("zlib" ,zlib)))
(arguments
`(#:make-flags `("V=1") ; more verbose compilation
@@ -126,7 +128,7 @@ everything from small to very large projects with speed and efficiency.")
`(("apr" ,apr)
("apr-util" ,apr-util)
("perl" ,perl)
- ("python" ,python)
+ ("python" ,python-2) ; incompatible with Python 3 (print syntax)
("sqlite" ,sqlite)
("zlib" ,zlib)))
(home-page "http://subversion.apache.org/")