summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-22 17:34:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-22 18:24:22 +0300
commit8ef843c711e73db2aac9e9b6e4193bc13b7c1dad (patch)
treec7d2ef6c3eb1283480fab2ae8dd2465e628c0861 /gnu/packages/version-control.scm
parent2ce516d359d9f2525f6b78f1de6dcee8de1c40ae (diff)
downloadpatches-8ef843c711e73db2aac9e9b6e4193bc13b7c1dad.tar
patches-8ef843c711e73db2aac9e9b6e4193bc13b7c1dad.tar.gz
gnu: aegis: Use 'modify-phases'.
* gnu/packages/version-control.scm (aegis)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm60
1 files changed, 29 insertions, 31 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 450f7f5a14..d0decefc9a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -964,39 +964,37 @@ accessed and migrated on modern systems.")
"--sharedstatedir=/var/com/aegis")
#:parallel-build? #f ; There are some nasty racy rules in the Makefile.
#:phases
- (alist-cons-before
- 'configure 'pre-conf
- (lambda _
- (substitute* (append '("configure"
- "etc/check-tar-gz.sh"
- "etc/patches.sh"
- "etc/test.sh"
- "script/aexver.in"
- "script/aebisect.in"
- "script/aeintegratq.in"
- "script/tkaegis.in"
- "script/test_funcs.in"
- "web/eg_oss_templ.sh"
- "web/webiface.html"
- "libaegis/getpw_cache.cc")
- (find-files "test" "\\.sh"))
- (("/bin/sh") (which "sh")))
- (setenv "SH" (which "sh")))
- (alist-replace
- 'check
- (lambda _
- (let ((home (string-append (getcwd) "/my-new-home")))
- ;; Some tests need to write to $HOME.
- (mkdir home)
- (setenv "HOME" home)
+ (modify-phases %standard-phases
+ (add-before 'configure 'pre-conf
+ (lambda _
+ (substitute* (append '("configure"
+ "etc/check-tar-gz.sh"
+ "etc/patches.sh"
+ "etc/test.sh"
+ "script/aexver.in"
+ "script/aebisect.in"
+ "script/aeintegratq.in"
+ "script/tkaegis.in"
+ "script/test_funcs.in"
+ "web/eg_oss_templ.sh"
+ "web/webiface.html"
+ "libaegis/getpw_cache.cc")
+ (find-files "test" "\\.sh"))
+ (("/bin/sh") (which "sh")))
+ (setenv "SH" (which "sh"))))
+ (replace 'check
+ (lambda _
+ (let ((home (string-append (getcwd) "/my-new-home")))
+ ;; Some tests need to write to $HOME.
+ (mkdir home)
+ (setenv "HOME" home)
- ;; This test assumes that flex has been symlinked to "lex".
- (substitute* "test/00/t0011a.sh"
- (("type lex") "type flex"))
+ ;; This test assumes that flex has been symlinked to "lex".
+ (substitute* "test/00/t0011a.sh"
+ (("type lex") "type flex"))
- ;; The author decided to call the check rule "sure".
- (zero? (system* "make" "sure"))))
- %standard-phases))))
+ ;; The author decided to call the check rule "sure".
+ (zero? (system* "make" "sure"))))))))
(home-page "http://aegis.sourceforge.net")
(synopsis "Project change supervisor")
(description "Aegis is a project change supervisor, and performs some of