summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-07-02 19:42:47 -0400
committerLeo Famulari <leo@famulari.name>2018-07-02 19:47:46 -0400
commit86163a017b1b16a672a202488f5bbb090e108fd1 (patch)
tree5e8894ba8e5e890f367c74be9ea2e857f10c3c18 /gnu/packages/version-control.scm
parentdb024183c9fa93289a45e816529e99001de0a7d1 (diff)
downloadpatches-86163a017b1b16a672a202488f5bbb090e108fd1.tar
patches-86163a017b1b16a672a202488f5bbb090e108fd1.tar.gz
gnu: libgit2: Update to 0.26.4 [fixes CVE-2018-11235].
* gnu/packages/version-control.scm (libgit2): Update to 0.26.4. (source): Adjust patch name. * gnu/packages/patches/libgit2-0.25.1-mtime-0.patch: Rename to ... * gnu/packages/patches/libgit2-mtime-0.patch: ... this. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 86d6afef3e..2bd59ae95f 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -419,7 +419,7 @@ everything from small to very large projects with speed and efficiency.")
(define-public libgit2
(package
(name "libgit2")
- (version "0.26.0")
+ (version "0.26.4")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/libgit2/libgit2/"
@@ -427,8 +427,8 @@ everything from small to very large projects with speed and efficiency.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1b3figbhp5l83vd37vq6j2narrq4yl9pfw6mw0px0dzb1hz3jqka"))
- (patches (search-patches "libgit2-0.25.1-mtime-0.patch"))
+ "15ybzypyggx64ba7i0zxnnbvzh7z34fcrkwk2xj54kmv1dha4br9"))
+ (patches (search-patches "libgit2-mtime-0.patch"))
;; Remove bundled software.
(snippet '(begin