summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-10-30 17:17:20 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-11-02 12:52:09 +0100
commitabb6a0e0d18f39cabd84b118d52659e996137d6f (patch)
tree4193d482939385cddabda4c37832c740639f21ba /gnu/packages/version-control.scm
parent223492f35025215f2ea07f61a75e53b96794e6ed (diff)
downloadpatches-abb6a0e0d18f39cabd84b118d52659e996137d6f.tar
patches-abb6a0e0d18f39cabd84b118d52659e996137d6f.tar.gz
gnu: git: Add PCRE support to "git grep".
* gnu/packages/version-control.scm (git)[inputs]: Add pcre2. [arguments]: Add "USE_LIBPCRE2" to make-flags. (git-minimal)[arguments]: Do not inherit "USE_LIBPCRE2" in make-flags.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 573fa6f8cc..cc4e4ca20e 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -183,14 +183,17 @@ as well as the classic centralized workflow.")
;; a problem in 'patch-shebangs'; see <https://bugs.gnu.org/31952>.
("bash-for-tests" ,bash)
- ;; For 'gitweb.cgi'
+ ;; For PCRE support in git grep (USE_LIBPCRE2).
+ ("pcre" ,pcre2)
+
+ ;; For 'gitweb.cgi'.
("perl-cgi" ,perl-cgi)
;; For 'git-svn'.
("subversion" ,subversion)
("perl-term-readkey" ,perl-term-readkey)
- ;; For 'git-send-email'
+ ;; For 'git-send-email'.
("perl-authen-sasl" ,perl-authen-sasl)
("perl-net-smtp-ssl" ,perl-net-smtp-ssl)
("perl-io-socket-ssl" ,perl-io-socket-ssl)
@@ -216,6 +219,8 @@ as well as the classic centralized workflow.")
(assoc-ref %build-inputs "bash-for-tests")
"/bin/bash")
+ "USE_LIBPCRE2=yes"
+
;; By default 'make install' creates hard links for
;; things in 'libexec/git-core', which leads to huge
;; nars; see <https://bugs.gnu.org/21949>.
@@ -505,6 +510,8 @@ everything from small to very large projects with speed and efficiency.")
(delete-file-recursively
(string-append out "/share/gitweb"))
#t)))))
+ ((#:make-flags flags)
+ `(delete "USE_LIBPCRE2=yes" ,flags))
((#:configure-flags flags)
''())
((#:disallowed-references lst '())